import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[[^]\\\\]*(?:\\\\.[^]\\\\]*)*\\]";
final String string = "[abc]\n"
+ "[1-9\\n\\t]\n"
+ "[ \\t\\]]\n"
+ "[\\\\\\]]\n"
+ "[[\\\\\\\\\\\\\\]]\n"
+ "The square brackets cannot be nested, by example in [[]], we want to match [[].\n\n"
+ "Although, since a \\] indicate an escaped bracket, we need to skip those. But a pattern such as \\\\] must be accepted. The following would not be matched.\n\n"
+ "[\\]\n"
+ "[\\\\\\]\n"
+ "[abc\\\\\\]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}