# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:[\n|\t])*.+?(?:[^;']|(?:'[^']+'))+;$"
test_str = ("SELECT * FROM database;\n"
"SELECT * FROM database WHERE somefield = 'somevalue';\n"
"SELECT * FROM database WHERE somefield = \"somevalue\";\n\n\n"
"EXPLAIN SELECT * FROM database WHERE somefield = \"somevalue\";\n"
"SELECT * FROM database WHERE somefield = 'somevalue' AND someotherfield = 'somemistypedstring;\n\n"
"SELECTing is hard, though, this is just text!;\n\n"
"SELECT\n"
" *\n"
"FROM\n"
" test_table\n"
"WHERE\n"
" test_row = 'Testing ; semicolon';\n\n"
"SELECT * FROM another_test_table;\n\n"
"INSERT INTO \n"
" table_name \n"
"VALUES \n"
" (value1,'value which contains semicolon ;;;;',value3,...);\n\n"
"WITH JOIN parcels\n"
"WHERE sp;\n\n\n"
"select * from accounts;\n\n"
"select * from events_stages_history;")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.