using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.{1})(?=(习近平总))";
string input = @"近平总书尊敬的主席同志,习近平总书记和我都是老百姓!习近平总书记是我们的好领导习近平总书!";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}