import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(['\"\"])((?:\\\\1|(?:(?!\\1)).)*)(\\1)|(?<OpenMatch>(\\{))|(?<CloseMatch>(\\}))";
final String string = "if (!(new[] { \"Command\", \"Click\" }).Any(d => xmlAttribute.Name.Equals(d,\n"
+ "StringComparison.CurrentCultureIgnoreCase))) continue;\n"
+ "if (!baseChain.Name.Contains(':')) return chain;\n"
+ "var checkAnyInherited = baseChain.Name.Split(':').Last().Split(',', ' ').Where(d => !string.IsNullOrEmpty(d)).Select(d => d.Trim()).ToList();\n"
+ "private static IEnumerable<StatementReferenceMaster> GetAllMethodsForClass(string className, int projectId)\n"
+ " {\n"
+ " using (ICodeVortoService codeVortoService = new CodeVortoService())\n"
+ " {\n"
+ " object[] parametersExp =\n"
+ " {\n"
+ " new MySqlParameter(\"@delim\", MySqlDbType.VarChar) {Value = \",\"},\n"
+ " new MySqlParameter(\"@className\", MySqlDbType.VarChar) {Value = className},\n"
+ " new MySqlParameter(\"@prjId\", MySqlDbType.Int32) {Value = projectId}\n"
+ " };\n"
+ " var callExtExpandedCode = codeVortoService.StatementReferenceMasterRepository\n"
+ " .ExecuteStoreProcedure<StatementReferenceMaster>(\"SpGetAllMethodsForClass\", parametersExp)\n"
+ " .ContinueWith(t => t.Result).Result;\n"
+ " return callExtExpandedCode;\n"
+ " }\n"
+ " }\n"
+ "@\"CREATE\\s+TABLE\"\n"
+ "@\"\\`(.*?)\\`\\s+\\(\"\n"
+ "@\"^\\`(.*?)\\`(.*)\"\n"
+ "@\"^PRIMARY\\s+KEY\"\n"
+ "@\"(.*)\\((.*)\\)\"\n"
+ "\"\"\n"
+ "\"\"\n"
+ "\"\"\n"
+ "\"(\"\n"
+ "\"-\"\n"
+ "\"DbScript\"\n"
+ " @\"CREATE\\s+TABLE\\s+(\\[dbo\\].)?(\\[)?(\\`)?(?<TableName>[a-zA-Z0-9_$]+)(\\])?(\\`)?\"\n"
+ "@\"^([\\s]+)?(\\[|\\`)?(?<FieldName>[a-zA-Z0-9_$]+)(\\]|\\`)?\"\n"
+ "\"TableName\"\n"
+ " @\"C:\\inetpub\\wwwroot\\flokapture\\ExtractedProjects\\LocationServicesSource\\Pods.Integration.Services.Location.Model\\LocationServiceModel.edmx\"\n"
+ "@\"^<EntityContainer\\s+Name=\\\"\"([^\\\"\"]*)\\\"\"\"\n"
+ "@\"^<EntityType\\s+Name=\\\"\"([^\\\"\"]*)\\\"\"\"\n"
+ "@\"StoreEntitySet=\\\"\"([^\\\"\"]*)\\\"\"\"\n"
+ "@\"^<Property\\s+\"\n"
+ "@\"^<EntityType\\s+Name=\\\"\"([^\\\"\"]*)\\\"\"|^<Property\\s+|^</EntityType>\\s+\"\n"
+ "\"<edmx:Mappings>\"\n"
+ "\"</EntityType>\"\n"
+ "\"Done\"\n"
+ "\"SELECT * FROM EntityAttributes WHERE ProjectId = \" \n"
+ " \" Group by EntityName;\"\n"
+ " @\"(?<VariableName>[a-z_]+)\\s*=\\s*new\\s+[a-z.0-9]+?\" \n"
+ " \"\\\\(\\\\)|[\\\\s]*[\\\\w]+\\\\s+(?<VariableName>[a-zA-Z0-9$_]+)[\\\\s]*=[\\\\s]*\"\n"
+ "\".\" ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}