# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([A-Z0-9]{4})/$1 /g;t' <<< "DE12345678901234567890"