using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z0-9]{4})";
string substitution = @"$1 ";
string input = @"DE12345678901234567890";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}