$re = '/([A-Z0-9]{4})/';
$str = 'DE12345678901234567890';
$subst = "$1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;