// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([A-Z0-9]{4})").unwrap();
let string = "DE12345678901234567890";
let substitution = "$1 ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}