package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`00[A-Fa-f0-9]{2}FF|00FF[A-Fa-f0-9]{2}|FF00[A-Fa-f0-9]{2}|FF[A-Fa-f0-9]{2}00|[A-Fa-f0-9]{2}00FF|[A-Fa-f0-9]{2}FF00`)
var str = `#FF00A0
#00FFC2
#00D3FF
#E400FF
#F5FF00
#FFB100`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}