$re = '/^[a-zA-Z]+0*/m';
$str = 'DE73456
DE71238
FR00034
FR00036
ES00038
US00039
DE00098';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;