#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\+?\d{1,3}(\-|\x20)?\(?\d+\)?((\-|\x20)?\d+)+$"
Local $sString = "+622191755194" & @CRLF & _
"622191755194" & @CRLF & _
"62-(21)-91755194" & @CRLF & _
"62-(21)-9175-5194" & @CRLF & _
"62 (21) 9175 5194" & @CRLF & _
"+62 (21) 9175 5194"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")