re = /^(([1-9]?[0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5])\.){3}([1-9]?[0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5])$/m
str = '172.18.0.25
254.0.24.36
127.0.0.1
127.0.0.256
0.21.02.0214
25.14.23.0
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end