#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([#№\p{Sc}]?\d+[%\p{Sc}]?)|(\p{P}?\s*)|(\w+))$"
Local $sString = "12" & @CRLF & _
"пробел" & @CRLF & _
"ert" & @CRLF & _
",пробел" & @CRLF & _
"erw12" & @CRLF & _
"все показывает не подошло, а я думаю что только последнее не подходить должно" & @CRLF & _
"в чем ошибся?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")