const regex = /\d{2,4}-?\d{3,4}-?\d{3,4}#?(\d+)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{2,4}-?\\d{3,4}-?\\d{3,4}#?(\\d+)?', 'g')
const str = `02-1234-5678#123
03-123-3339#123
039-546-469
039546469
0981-340-611
0981340611
0226665787
032241234#12`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}