using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\D+)?(?:(?:[4-7](?:(?:\.|\,)[1-9])?)|(?:[5-8](?:(?:\.|\,)0)?))(?:(?:\s?gb)|\s?giga|\sgigabyte)?(?:.*)";
string input = @"4.5 polegadas (~ 64,3% relação tela-corpo)
5,5 polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3
5,5 polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3
5""-6"" polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3
^(?:(6(?:\.|\,)0)|(5(?:\.|\,)[1-9]))(.*)
\s?(?:(?:\d+)(?:\.|\,)?(?:\d+)?)(?:""|''|\x60|'|´|”)
(?:(5(?:\.|\,)0)|(4(?:\.|\,)[1-9]))(.*)
(4(?:\.|\,)[1-9])(.*) => 4-5
(5(?:\.|\,)[0]))(.*) => 4-5";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}