# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:\D+)?(?:(?:[4-7](?:(?:\.|\,)[1-9])?)|(?:[5-8](?:(?:\.|\,)0)?))(?:(?:\s?gb)|\s?giga|\sgigabyte)?(?:.*)"
test_str = ("4.5 polegadas (~ 64,3% relação tela-corpo)\n\n"
"5,5 polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3\n\n"
"5,5 polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3\n\n"
"5\"-6\" polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3\n\n"
"^(?:(6(?:\\.|\\,)0)|(5(?:\\.|\\,)[1-9]))(.*)\n"
"\\s?(?:(?:\\d+)(?:\\.|\\,)?(?:\\d+)?)(?:\"|''|\\x60|'|´|”)\n\n"
"(?:(5(?:\\.|\\,)0)|(4(?:\\.|\\,)[1-9]))(.*)\n\n"
"(4(?:\\.|\\,)[1-9])(.*) => 4-5\n"
"(5(?:\\.|\\,)[0]))(.*) => 4-5")
matches = re.search(regex, test_str, re.DOTALL | re.IGNORECASE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.