const regex = /(?:\[.+\])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\[.+\\])', 'gm')
const str = `related to such contracts.[79]
References[edit]
smart contract platform.[65][66]
Quorum.[63] It's designed
separate version became Ethereum (ETH) with the theft reversed,[12]
and the original chain continued as Ethereum Classic (ETC).[13]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);