# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\[.+\])"
test_str = ("related to such contracts.[79]\n"
"References[edit]\n"
"smart contract platform.[65][66]\n"
"Quorum.[63] It's designed\n\n"
"separate version became Ethereum (ETH) with the theft reversed,[12] \n"
"and the original chain continued as Ethereum Classic (ETC).[13]")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.