re = /(\d+)?(?:|[^\/]+)(?:|\/)$/
str = ' site.loc/product/7-hello-world/65-gtyjkj45545/543-5454'
# Print the match result
str.match(re) do |match|
puts match.to_s
end