using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^,()]+(?:\((?:(?R)(,(?R))*|[^,()]+|)\))?";
string input = @"abc, f(1, 2, 3), g(f(abc)), 3";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}