package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^,()]+(?:\((?:(?R)(,(?R))*|[^,()]+|)\))?`)
var str = `abc, f(1, 2, 3), g(f(abc)), 3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}