re = /[^,()]+(?:\((?:(?R)(,(?R))*|[^,()]+|)\))?/
str = 'abc, f(1, 2, 3), g(f(abc)), 3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end