Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^([\w.]{1,})\.([\w]{3,4})\.([\w]{3,4})$
/
gm
Input 1
1
New
file.txt file.txt.txt file.one.two.thre file.one.two.three file.google.txt.jar jim.joe.chris something.filename.pdf.lnk filename.pdf.123 thisfile.hasadotbutonlyone.exe thisfile.xlsx.xlsx thisfile.12.123