using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=a)(?=b)|(?<=b)(?=a)";
string substitution = @"|";
string input = @"ab
aba
ababa
aaabbbaaabaaaaaab";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}