package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([A-Z][\d]|[\d][A-Z]|[A-Z]{2})(\d{1,})$`)
var str = `KL1234
9F1
K9123
2345
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}