$re = '/^([A-Z][\d]|[\d][A-Z]|[A-Z]{2})(\d{1,})$/m';
$str = 'KL1234
9F1
K9123
2345
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);