// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([A-Z][\d]|[\d][A-Z]|[A-Z]{2})(\d{1,})$").unwrap();
let string = "KL1234
9F1
K9123
2345
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}