re = /(?<!\p{C})\b\w+\b(?!\p{C})/m
str = 'word without control characters
word with control character between'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end