#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[9][2-5]\d{7}"
Local $sString = "929164344" & @CRLF & _
"915392194" & @CRLF & _
"943757798" & @CRLF & _
"922955344" & @CRLF & _
"914094882" & @CRLF & _
"990824719" & @CRLF & _
"991259647" & @CRLF & _
"925212121" & @CRLF & _
"954000000" & @CRLF & _
"964000000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")