re = /(?m)^([A-D]:.*?)correct$((?:\n.*)*?\nx{3,})/m
str = '1: How old am I?
A: 8 days
B: 75
C: 100
D: 99correct
xxxxxxxxxxxx
2: What is your favorite color?
A: blue
B: greencorrect
C: red
D: blue
xxxxxxxxxxxx'
subst = '\\1\\2 \\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result