#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^" & @CRLF & _
"(?=(?:[^A-Z]*[A-Z]){2})" & @CRLF & _
"(?=(?:[^a-z]*[a-z]){2})" & @CRLF & _
"(?=(?:\D*\d){2})" & @CRLF & _
"(?=(?:[^$%&!#]*[$%&!#]){2})" & @CRLF & _
".{8,}" & @CRLF & _
"$"
Local $sString = "a9T%5Q$f" & @CRLF & _
"a9T%5r$f"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")