import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n"
+ "(?=(?:[^A-Z]*[A-Z]){2})\n"
+ "(?=(?:[^a-z]*[a-z]){2})\n"
+ "(?=(?:\\D*\\d){2})\n"
+ "(?=(?:[^$%&!#]*[$%&!#]){2})\n"
+ ".{8,}\n"
+ "$";
final String string = "a9T%5Q$f\n"
+ "a9T%5r$f";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}