#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)(?<!\]\()(\b(https?|ftp):\/\/[-A-Z0-9+&@#\/%?=~_|!:,.;]*[-A-Z0-9+&@#\/%=~_|])(?!\]\()"
Local $sString = "Login in to My site [https://example.com/](https://example.com/) and select Something > Select below details further." & @CRLF & _
"" & @CRLF & _
"(https://example.com/abc/1.html)" & @CRLF & _
"" & @CRLF & _
"Also have a look at https://example.com/abc/1.html"
Local $sSubst = "[$1]($1)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)