$re = '/\d{2}\.\d{2}/';
$str = '31.12.17';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);