# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:A=|\G)\d):/$1./gm;t' <<< "A=1:2:3 B=1:2:3 A=1:2:3:4:5 B=1:2:3"