re = /((?:A=|\G)\d):/m
str = 'A=1:2:3 B=1:2:3 A=1:2:3:4:5 B=1:2:3'
subst = '$1.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result