$re = '/(^\+\d\s\(\d{3}\)\s\d{3}\-\d{4}$|^\+\d{1,3}\s\d{2,3}\s\d{2,3}\s\d{2,3}\s\d{2})/m';
$str = '+1 (555) 555-5555
+1 (555) 555-55555
+90 532 581 98 18
+90 532 581 98 186
+358 44 944 30 13
+358 44 944 30 133';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);