import Foundation
let pattern = #"(^\+\d\s\(\d{3}\)\s\d{3}\-\d{4}$|^\+\d{1,3}\s\d{2,3}\s\d{2,3}\s\d{2,3}\s\d{2})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
+1 (555) 555-5555
+1 (555) 555-55555
+90 532 581 98 18
+90 532 581 98 186
+358 44 944 30 13
+358 44 944 30 133
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)