import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@e(?!ureka\\.com).?u.?r.?e.?k.?a\\.com";
final String string = "jcarter@eurreka.com\n"
+ "jcarter@euureka.com\n"
+ "jcarter@eurekaa.com\n"
+ "jcarter@eeureka.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}