package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+(?:\.\d{2})?(?: ?& ?\d+(?:\.\d{2})?)*$`)
var str = `12
12.12
12 & 129.12 & 11
12 & 129. & 11
12 & .129
12 & 129..1
12 & 129.111
&&&1
12 ---> (pass)
12.12 ---> (pass)
12 & 129.12 & 11 --- >(pass)
12 & 129. & 11 ---> (should not pass)
12 & .129 ---> (should not pass)
12 & 129..1 (should not pass)
12 & 129.111 (should not pass)
&&&1 (should not pass)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}