use strict;
my $str = '12
12.12
12 & 129.12 & 11
12 & 129. & 11
12 & .129
12 & 129..1
12 & 129.111
&&&1
12 ---> (pass)
12.12 ---> (pass)
12 & 129.12 & 11 --- >(pass)
12 & 129. & 11 ---> (should not pass)
12 & .129 ---> (should not pass)
12 & 129..1 (should not pass)
12 & 129.111 (should not pass)
&&&1 (should not pass)';
my $regex = qr/^\d+(?:\.\d{2})?(?: ?& ?\d+(?:\.\d{2})?)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}