// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d+(?:\.\d{2})?(?: ?& ?\d+(?:\.\d{2})?)*$").unwrap();
let string = "12
12.12
12 & 129.12 & 11
12 & 129. & 11
12 & .129
12 & 129..1
12 & 129.111
&&&1
12 ---> (pass)
12.12 ---> (pass)
12 & 129.12 & 11 --- >(pass)
12 & 129. & 11 ---> (should not pass)
12 & .129 ---> (should not pass)
12 & 129..1 (should not pass)
12 & 129.111 (should not pass)
&&&1 (should not pass)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}