// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<span[^>]+>(.*?)</span>").unwrap();
let string = "<td class=\"class2\"> </td>
<td class=\"class2\" align=\"right\"><span class=\"DarkText\">I WANT THIS TEXT</span></td>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}