#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\(((?:[^()]|(?R))*)\)"
Local $sString = "((Lorem) ipsum dolor sit amet)" & @CRLF & _
"(consectetur adipiscing elit.)(Etiam" & @CRLF & _
"suscipit" & @CRLF & _
"pulvinar congue.)" & @CRLF & _
"((Vivamus) eu faucibus enim.)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")