import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:http(?:s)?:\\/\\/)?(?:(?:www)\\.(?:tiktok\\.com)(?:\\/)(?!foryou)(@[a-zA-z0-9]+)(?:\\/)(?:video)(?:\\/)([\\d]+)|(?:m)\\.(?:tiktok\\.com)(?:\\/)(?!foryou)(?:v)(?:\\/)?(?=([\\d]+)\\.html))";
final String string = "https://m.tiktok.com/h5/share/usr/6641141594707361797.html\n\n"
+ "https://www.tiktok.com/embed/6567659045795758085\n"
+ "https://www.tiktok.com/share/user/6567659045795758085\n"
+ "https://www.tiktok.com/trending?shareId=6744531482393545985\n\n"
+ "https://www.tiktok.com/foryou?is_copy_url=1&is_from_webapp=v1&item_id=7103185591575088411#/@jd77777778/video/7103185591575088411\n\n"
+ "https://www.tiktok.com/foryou?is_copy_url=1&is_from_webapp=v1&item_id=7103185591575088411\n\n"
+ "https://www.tiktok.com/foryou?is_copy_url=1&is_from_webapp=v1&item_id=7103185591575088411#/@jd77777778/video/7103185591575088411\n\n\n"
+ "https://www.tiktok.com/v/6749869095467945218.html\n"
+ "https://www.tiktok.com/v/6749869095467945218\n"
+ "https://m.tiktok.com/v/6749869095467945218\n"
+ "https://m.tiktok.com/@cchelseameow/video/6751181801206729990\n"
+ "https://m.tiktok.com/@jd77777778/video/7103185591575088411?is_from_webapp=1&sender_device=pc\n\n\n\n"
+ "https://m.tiktok.com/v/6749869095467945218.html\n"
+ "https://www.tiktok.com/@cchelseameow/video/6751181801206729990\n"
+ "https://www.tiktok.com/@jd77777778/video/7103185591575088411?is_from_webapp=1&sender_device=pc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}