use strict;
my $str = 'https://m.tiktok.com/h5/share/usr/6641141594707361797.html
https://www.tiktok.com/embed/6567659045795758085
https://www.tiktok.com/share/user/6567659045795758085
https://www.tiktok.com/trending?shareId=6744531482393545985
https://www.tiktok.com/foryou?is_copy_url=1&is_from_webapp=v1&item_id=7103185591575088411#/@jd77777778/video/7103185591575088411
https://www.tiktok.com/foryou?is_copy_url=1&is_from_webapp=v1&item_id=7103185591575088411
https://www.tiktok.com/foryou?is_copy_url=1&is_from_webapp=v1&item_id=7103185591575088411#/@jd77777778/video/7103185591575088411
https://www.tiktok.com/v/6749869095467945218.html
https://www.tiktok.com/v/6749869095467945218
https://m.tiktok.com/v/6749869095467945218
https://m.tiktok.com/@cchelseameow/video/6751181801206729990
https://m.tiktok.com/@jd77777778/video/7103185591575088411?is_from_webapp=1&sender_device=pc
https://m.tiktok.com/v/6749869095467945218.html
https://www.tiktok.com/@cchelseameow/video/6751181801206729990
https://www.tiktok.com/@jd77777778/video/7103185591575088411?is_from_webapp=1&sender_device=pc';
my $regex = qr/(?:http(?:s)?:\/\/)?(?:(?:www)\.(?:tiktok\.com)(?:\/)(?!foryou)(@[a-zA-z0-9]+)(?:\/)(?:video)(?:\/)([\d]+)|(?:m)\.(?:tiktok\.com)(?:\/)(?!foryou)(?:v)(?:\/)?(?=([\d]+)\.html))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}