import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([^,]*,){2})";
final String string = "nsi_file_status,host=pi-test.rusklimat.ru Message_000_113_CountRecord=5,endTime=1695132572,iterator=1,longtime=30,processFail=0,processFailDomainException=0,processFailException=0,processFailInvalidArgumentException=0,processSuccess=5,processTotal=5,startTime=1695132542,timeStamp=1695132542 1695132700000000000\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}