$re = '/[A-Z]\d|[^\d\n]+/m';
$str = 'B9966
ch6258
028
chIRZ170
IRZ170
B9966A1';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;