# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\d{2}[A-Z]-[A-Z]+$"
test_str = ("PASS :\n"
"16B-SCHUIF\n"
"32B-MATH\n"
"08B-SCHUIF\n\n"
"FAIL :\n"
"8B-SCHUIF\n"
"16B-42SCHUIF\n"
"16BSCHUIF\n"
"16-SCHUIF\n"
"16B-SCHUIF42A")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.