re = /Lib\.myfunction\s*\(\s*\S+(?:,\s*\S+)*\s*\)/m
str = 'Lib.myfunction( arg0, arg1,
arg2, arg3 )
other text.
Lib.myfunction ( arg0, arg1, arg2, arg3 )
Lib.myfunction ( arg0,
arg1,
arg2,
arg3
)
blah.blah ( arg0, arg1,
arg2, arg3 )'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end